职业教育新东方网 > 职业教育 > 计算机 > 等级考试 > 计算机四级 > 网络工程师 > 文章正文

2011年计算机四级网络工程师知识点(7)

分享到:

2011-09-22 20:22  作者:  来源:考试大-  字号:T|T

  第七章:路由器的原理及配置

  Internet 就是用路由器加专线的方法连接了成千上万个网络而构成的

  路由选择的核心就是确定下一跳路由器的 IP 地址 路由表是路由选择的核心

  路由表主要内容:目的网络地址,下一跳路由器地址和目的端口等信息,缺省路 由信息

  分组转发通常称分组交换

  缺省路由又称缺省网关,一般路由器的缺省网关是指向连往 Internet 出口的路由器

  几种路由协议管理距离:直接连接:0 静态路由:1 外部 BGP:20 内部 EIGRP:90

  IGRP:100 OSPF:110 RIP:120 外部 EIGRP:170 内部 BGP:200 未知:255

  路由配置常用命令

  Router#write memory 保存到路由器的 NVRAM 中

  Router#write network tftp 保存到 tftp 服务器

  Router#write erase 删除路由器全部配置

  show interface 查看路由器的接口

  show running-config 查看路由的配置 密码 接口 IP 地址 ACL NAT

  show version 查看路由器版本 配置寄存器的值

  show ip route 查看路由表

  show ip protocal 查看路由器运行的动态路由协议

  config t Router(config)# Router(config)#hostname Router1

  Router1(config)#enable password aaa

  Router1(config)#enable secret aaaa

  配置 Telnet 密码 TCP 23

  Router1(config)#line vty 0 4

  Router1(config-line)#password aaa 设置 Telnet 密码

  Router1(config-line)#login 要求必须登录

  Telnet 如果不需要密码执行以下命令

  Router1(config)#line vty 0 4

  Router1(config-line)#no login

  Router1(config-line)#no password

  配置路由器接口 IP 地址

  Router1(config)#interface fastEthernet 0/0

  Router1(config-if)#ip address 192.168.0.1 255.255.255.0

  Router1(config-if)#no sh

  Router1(config)#interface serial 2/0

  Router1(config-if)#clock rate 64000 在 DCE 端配置时钟频率

  Router1(config-if)#ip address 10.0.0.1 255.255.255.0

  Router1(config-if)#no sh

  管理 Cisco 互联网络

  路由器的结构:中央处理器 CPU; 内存 MENORY;存储器 Storage ;接口:INTERFACE

  内存:RAM----相当于计算机的内存;配置路由器的设置默认是----RAM ;NVRAM ----相当于硬盘存放;

  ROM----相当于计算机的 BIOS , 不能删除 存放 Bootstarp POST 微型 IOS

  Flash------存放 IOS

  路由器工作模式(用户模式;特权模式;设置模式;全局配置模式;其他配置模式;RXBOOT 模式

  解析主机名

  Router(config)#ip host Router0 172.16.5.1

  Router#telnet Router0

  网络排错

  ipconfig /all 查看计算机的 IP 配置,包括 IP 地址,子网掩码、网关 DNS 服务 器设置

  ping 网关 IP 地址

  ping 202.99.160.68 or 202.99.168.8 测试到 Internet 的网络层是否通

  ping www.inhe.net 域名是否能解析成 IP 地址

  telnet www.inhe.net 80 测试应用层是否畅通 23 默认端口

  pathping www.inhe.net 跟踪数据包路径和计算丢包情况

  tracert ip 类似与计算机上的 pathping 能够跟踪数据包路径不计算机丢包情况

  静态路由管理员告诉路由器到各个网段如何转发

  Router(config)#ip route 192.168.6.0 255.255.255.0 192.168.1.2 ?(可以更改管理距离 AD)

  动态路由路由器自己来学习到各个网段如何转发

  静态路由不能自动根据网络变换而变化 规模小没有环

  在计算机上添加路由表

  route add 192.168.2.0 mask 255.255.255.0 192.168.1.2 添加路由表

  route print 显示计算机上的路由表

  netstat -r

  动态路由网络规模较大 or 具有网状结构的网络

  RIP 周期性广播路由表 30 秒 度量值是跳数 15 跳 16 跳认为不可到达

  RIPv1 广播传播路由信息 支持等长子网 不支持变长子网和不连续子网

  RIPv2 多播传播路由信息 支持变长子网 和 不连续子网(关闭自动汇总)传播 路由信息中包含了子网掩码信息

  EIGRP 相当于 RIPv2 支持变长子网 关掉汇总,支持不连续子网。

  Router#config t

  Router(config)#router rip

  Router(config-router)#network 172.16.0.0

  Router(config-router)#network 10.0.0.0

  Router(config-router)#version 2

  Router(config-router)#no auto-summary

  Router#show ip protocols 显示配置的所有动态路由协议

  OSPF 路由表由路由根据链路状态数据库算出来的,不出现环路,路由器之间更新的是链路状态,度量值带宽。触发式更新。

关键字:

相关文章导读

热点课讯

精彩问答

提问